UVa1592 - Database
题设
Peter studies the theory of relational databases. Table in the relational database consists of values that are arranged in rows and columns.
There are different normal forms that database may adhere to. Normal forms are designed to minimize the redundancy of data in the database. For example, a database table for a library might have a row for each book and columns for book name, book author, and author’s email.
If the same author wrote several books, then this representation is clearly redundant. To formally define this kind of redundancy Peter has introduced his own normal form. A table is in Peter’s Normal Form (PNF) if and only if there is no pair of rows and a pair of columns such that the values in the corresponding columns are the same for both rows.
1 | 2 | 3 |
---|---|---|
How to compete in ACM ICPC | Peter | [email protected] |
How to win ACM ICPC | Michael | [email protected] |
Notes from ACM ICPC champion | Michael | [email protected] |
The above table is clearly not in PNF, since values for 2rd and 3rd columns repeat in 2nd and 3rd rows. However, if we introduce unique author identifier and split this table into two tables — one containing book name and author id, and the other containing book id, author name, and author email, then both resulting tables will be in PNF.
1 | 2 |
---|---|
How to compete in ACM ICPC | 1 |
How to win ACM ICPC | 2 |
Notes from ACM ICPC champion | 3 |
1 | 2 | 3 |
---|---|---|
1 | Peter | [email protected] |
2 | Michael | [email protected] |
Given a table your task is to figure out whether it is in PNF or not.
Input
Input contains several datasets. The first line of each dataset contains two integer numbers n and m (1 ≤ n ≤ 10000,1 ≤ m ≤ 10), the number of rows and columns in the table. The following n lines contain table rows. Each row has m column values separated by commas. Column values consist of ASCII characters from space (ASCII code 32) to tilde (ASCII code 126) with the exception of comma (ASCII code 44). Values are not empty and have no leading and trailing spaces. Each row has at most 80 characters (including separating commas).
Output
For each dataset, if the table is in PNF write to the output file a single word “YES” (without quotes). If the table is not in PNF, then write three lines. On the first line write a single word “NO” (without quotes). On the second line write two integer row numbers r1 and r2 (1 ≤ r1,r2 ≤ n,r1 ̸= r2), on the third line write two integer column numbers c1 and c2 (1 ≤ c1,c2 ≤ m,c1 ̸= c2), so that values in columns c1 and c2 are the same in rows r1 and r2.
Sample Input
1
2
3
4
5
6
7
3 3
How to compete in ACM ICPC,Peter,[email protected]
How to win ACM ICPC,Michael,[email protected]
Notes from ACM ICPC champion,Michael,[email protected]
2 3
1,Peter,[email protected]
2,Michael,[email protected]
Sample Output
1
2
3
4
NO
2 3
2 3
YES
题解
这道题预处理字符串后直接暴力和穷举即可,注意不能对r1,r2,c1,c2进行四重循环,会TLE,可以对c1,c2,r进行穷举,并将每一行对应的二元组存入一个map中,这里用的是一个hashmap,存key的方法是将一个二元组对应到唯一的long long数上。
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
#include <iostream>
#include <sstream>
#include <unordered_map>
using namespace std;
typedef long long LL;
const int N = 10010, M = 20, P = 1e9 + 7;
int n, m, idx;
int r1, r2, c1, c2;
int g[N][M];
unordered_map<string, int> dict;
unordered_map<LL, int> mp;
bool solve() {
for (int i = 1; i <= m; i++) {
for (int j = i + 1; j <= m; j++) {
mp.clear();
for (int k = 1; k <= n; k++) {
int a = g[k][i], b = g[k][j];
LL key = (LL)a * P + b;
if (mp.count(key)) {
r1 = mp[key], r2 = k;
c1 = i, c2 = j;
return true;
}
mp[key] = k;
}
}
}
return false;
}
int main() {
while (scanf("%d%d", &n, &m) == 2) {
idx = 0;
dict.clear();
string line;
string s;
getchar();
for (int i = 1; i <= n; i++) {
getline(cin, line);
istringstream iss(line);
for (int j = 1; j <= m; j++) {
getline(iss, s, ',');
if (!dict.count(s)) dict[s] = ++idx;
g[i][j] = dict[s];
}
}
if (solve())
printf("NO\n%d %d\n%d %d\n", r1, r2, c1, c2);
else
puts("YES");
}
return 0;
}