Post

AcWing1072 - 树的最长路径

给定一棵树,树中包含 n 个结点(编号1~n)和 n−1 条无向边,每条边都有一个权值。

现在请你找到树中的一条最长路径。

换句话说,要找到一条路径,使得使得路径两端的点的距离最远。

注意:路径中可以只包含一个点。

输入格式

第一行包含整数 n。

接下来 n−1 行,每行包含三个整数 ai,bi,ci,表示点 ai 和 bi 之间存在一条权值为 ci 的边。

输出格式

输出一个整数,表示树的最长路径的长度。

数据范围

1≤n≤10000, 1≤ai,bi≤n, −105≤ci≤105

输入样例:

1
2
3
4
5
6
6
5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

输出样例:

1
22

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
#include <cstring>
#include <iostream>
using namespace std;
const int N = 10010, M = N * 2;

int n;
int h[N], ne[M], e[M], w[M], idx;
int ans;

void add(int a, int b, int c) {
  e[idx] = b, w[idx] = c, ne[idx] = h[a], h[a] = idx++;
}

int dfs(int u, int father) {
  int dist = 0;
  int d1 = 0, d2 = 0;
  
  for (int i = h[u]; ~i; i = ne[i]) {
    int j = e[i];
    if (j == father) continue;
    int d = dfs(j, u) + w[i];
    dist = max(dist, d);
    
    if (d >= d1) d2 = d1, d1 = d;
    else if (d > d2) d2 = d;
  }
  
  ans = max(ans, d1 + d2);
  
  return dist;
}

int main() {
  scanf("%d", &n);
  memset(h, -1, sizeof h);
  for (int i = 0; i < n - 1; i++) {
    int a, b, c;
    scanf("%d%d%d", &a, &b, &c);
    add(a, b, c), add(b, a, c);
  }
  
  dfs(1, -1);
  
  cout << ans << endl;
  
  return 0;
}
This post is licensed under CC BY 4.0 by the author.